Issue:
The Milestone Smart Client displays green blocks / artifacts in the images.
Root Cause:
“SV2/OMNI3 single stream RTP/TCP has artifacts in Milestone if QP>=28.”
So current solution if this is encountered is switch streaming to UDP and set QP value lower than 28.
Resolution:
Important Notes:
- The resolution documented below requires the Streaming Mode be set to RTP/UDP and that Windows Firewall exceptions be implemented.
- Previous versions of Milestone supported UDP as a Streaming Mode.
- Milestone no longer supports UDP in current revisions (v12.2a / v13.2a or later). The drop down menus are present but they are not functional. The resulting connection error is in their forum and affects other manufacturers as well: https://supportcommunity.milestonesys.com/s/question/0D50O00005YcxPNSAZ/how-to-debug-nonplaying-udprtp-video-stream-?language=en_US)
Validate the cameras work with UDP with the Windows Firewall disabled.
- Change the Streaming Mode to UDP on the cameras.
- The streams should disconnect with an error "Connection to .... Trying to reconnect..."
- Go into Windows Firewall and temporarily disable it.
- The camera's should reconnect and you should be able to view the Live / Recorded video in the Smart Client.
Validate the cameras work with UDP with the Windows Firewall enabled
- The network administrator must make exceptions in the Windows Firewall.
- RTSP = 554
- HTTP = 80 or 8080
- HTTPS = 443
- TFTP = 69
- UDP = full range
- RTP = 10000 - 20000
- Windows Firewall Exceptions for Milestone
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